How to securely install Drupal Thunder using composer

How to securely install Drupal Thunder using composer

Installing Drupal 8´s Thunder is somehow very complicated, but very easy too if you know the right steps:

1. From the apache root download and build the project:
​composer create-project burdamagazinorg/thunder-project thunder --stability dev --no-interaction --no-install --prefer-dist --profile

2. Go into your new folder and install:and update with dependencies
composer install && composer update --with-dependencies

3. Using your browser go to your URL and install as you normally would do
Done!

If the Status Report complains about the Slick Library not being installed rename the folder within the libraries folder:

cd /var/www/html/thunder/docroot/libraries && mv slick-carousel/ slick

How to install Social Auth Google, Social Auth Twitter and Social Auth Facebook using composer

I had a hard time installing the OpenSocial Drupal8 Distribution.

So for those of you who have the same problem, here is how to get rid of the dependencies warnings with missing AUTH libraries:

composer require "drupal/social_api:1.x-dev" "drupal/social_auth:1.x-dev" "drupal/social_auth_google:1.x-dev"
composer require "drupal/social_api:1.x-dev" "drupal/social_auth:1.x-dev" "drupal/social_post_twitter:1.x-dev"
composer require "drupal/simple_fb_connect:3.x-dev"

drush dl mit Composer ersetzen

Da Composer etwaige Abhängigkeiten eines Drupal Moduls von einem anderen mitberücksichtigt macht es Sinn anstatt
drush dl
composer require

zu nutzen. Weitere Optionen für die Nutzung von composer mit Drupal wären z.B.:

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--sort-packages] [packages1] ... [packagesN]

 

Stichworte: