How to install Social Auth Google, Social Auth Twitter and Social Auth Facebook using composer

I had a hard time installing the OpenSocial Drupal8 Distribution.

So for those of you who have the same problem, here is how to get rid of the dependencies warnings with missing AUTH libraries:

composer require "drupal/social_api:1.x-dev" "drupal/social_auth:1.x-dev" "drupal/social_auth_google:1.x-dev"
composer require "drupal/social_api:1.x-dev" "drupal/social_auth:1.x-dev" "drupal/social_post_twitter:1.x-dev"
composer require "drupal/simple_fb_connect:3.x-dev"

Diesen Beitrag weiterempfehlen